<!doctype html>

<!--[if lt IE 7]><html lang="en-US" class="no-js lt-ie9 lt-ie8 lt-ie7"><![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" class="no-js"><!--<![endif]-->

	<head>
		<meta charset="utf-8">

				<meta http-equiv="X-UA-Compatible" content="IE=edge">

		<title>Vim 9.0 is Available on Arch Linux - Fasterland</title>

				<meta name="HandheldFriendly" content="True">
		<meta name="MobileOptimized" content="320">
		<meta name="viewport" content="width=device-width, initial-scale=1"/>

				<link rel="apple-touch-icon" href="https://fasterland.net/wp-content/themes/fasterland2/library/images/apple-touch-icon.png">
		<link rel="icon" href="https://fasterland.net/wp-content/themes/fasterland2/favicon.png">
		<!--[if IE]>
			<link rel="shortcut icon" href="https://fasterland.net/wp-content/themes/fasterland2/favicon.ico">
		<![endif]-->
				<meta name="msapplication-TileColor" content="#f01d4f">
		<meta name="msapplication-TileImage" content="https://fasterland.net/wp-content/themes/fasterland2/library/images/win8-tile-icon.png">
            <meta name="theme-color" content="#121212">

		<link rel="pingback" href="https://fasterland.net/xmlrpc.php">

				<style type='text/css'>Default CSS Comment</style><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<!-- Social Warfare v4.3.0 https://warfareplugins.com - BEGINNING OF OUTPUT -->
<style>
	@font-face {
		font-family: "sw-icon-font";
		src:url("https://fasterland.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0");
		src:url("https://fasterland.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0#iefix") format("embedded-opentype"),
		url("https://fasterland.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.3.0") format("woff"),
		url("https://fasterland.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.3.0") format("truetype"),
		url("https://fasterland.net/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.3.0#1445203416") format("svg");
		font-weight: normal;
		font-style: normal;
		font-display:block;
	}
</style>
<!-- Social Warfare v4.3.0 https://warfareplugins.com - END OF OUTPUT -->


	<!-- This site is optimized with the Yoast SEO plugin v19.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Vim 9.0, the terminal text editor has been updated with a major release and it&#039;s already available on Arch Linux. Let see how install it!" />
	<link rel="canonical" href="https://fasterland.net/vim-9-0-is-available-on-arch-linux.html" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Vim 9.0 is Available on Arch Linux - Fasterland" />
	<meta property="og:description" content="Vim 9.0, the terminal text editor has been updated with a major release and it&#039;s already available on Arch Linux. Let see how install it!" />
	<meta property="og:url" content="https://fasterland.net/vim-9-0-is-available-on-arch-linux.html" />
	<meta property="og:site_name" content="Fasterland" />
	<meta property="article:publisher" content="https://www.facebook.com/fasterland.net" />
	<meta property="article:author" content="https://www.facebook.com/faster3ck" />
	<meta property="article:published_time" content="2022-06-30T12:10:13+00:00" />
	<meta property="article:modified_time" content="2022-06-30T12:13:49+00:00" />
	<meta property="og:image" content="http://fasterland.net/wp-content/uploads/2022/06/vim.png" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="667" />
	<meta property="og:image:type" content="image/png" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@faster3ck" />
	<meta name="twitter:site" content="@faster3ck" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Francesco Mondello" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://fasterland.net/#website","url":"https://fasterland.net/","name":"Fasterland","description":"Welcome to Fasterland","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://fasterland.net/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://fasterland.net/vim-9-0-is-available-on-arch-linux.html#primaryimage","url":"https://i0.wp.com/fasterland.net/wp-content/uploads/2022/06/vim.png?fit=1000%2C667&ssl=1","contentUrl":"https://i0.wp.com/fasterland.net/wp-content/uploads/2022/06/vim.png?fit=1000%2C667&ssl=1","width":1000,"height":667,"caption":"vim arch linux text editor"},{"@type":"WebPage","@id":"https://fasterland.net/vim-9-0-is-available-on-arch-linux.html#webpage","url":"https://fasterland.net/vim-9-0-is-available-on-arch-linux.html","name":"Vim 9.0 is Available on Arch Linux - Fasterland","isPartOf":{"@id":"https://fasterland.net/#website"},"primaryImageOfPage":{"@id":"https://fasterland.net/vim-9-0-is-available-on-arch-linux.html#primaryimage"},"datePublished":"2022-06-30T12:10:13+00:00","dateModified":"2022-06-30T12:13:49+00:00","author":{"@id":"https://fasterland.net/#/schema/person/a6d5729cf873ef727369523d98db3807"},"description":"Vim 9.0, the terminal text editor has been updated with a major release and it's already available on Arch Linux. Let see how install it!","breadcrumb":{"@id":"https://fasterland.net/vim-9-0-is-available-on-arch-linux.html#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://fasterland.net/vim-9-0-is-available-on-arch-linux.html"]}]},{"@type":"BreadcrumbList","@id":"https://fasterland.net/vim-9-0-is-available-on-arch-linux.html#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Vim 9.0 is Available on Arch Linux"}]},{"@type":"Person","@id":"https://fasterland.net/#/schema/person/a6d5729cf873ef727369523d98db3807","name":"Francesco Mondello","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://fasterland.net/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/b81ae0bffd10a33d70ef6b76c27fa0f1?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/b81ae0bffd10a33d70ef6b76c27fa0f1?s=96&d=mm&r=g","caption":"Francesco Mondello"},"sameAs":["http://fasterland.net","https://www.facebook.com/faster3ck","https://twitter.com/faster3ck"],"url":"https://fasterland.net/author/faster3ck"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Fasterland &raquo; Feed" href="https://fasterland.net/feed" />
<link rel="alternate" type="application/rss+xml" title="Fasterland &raquo; Comments Feed" href="https://fasterland.net/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Fasterland &raquo; Vim 9.0 is Available on Arch Linux Comments Feed" href="https://fasterland.net/vim-9-0-is-available-on-arch-linux.html/feed" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.6.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-50305127-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/fasterland.net\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='social-warfare-block-css-css'  href='https://fasterland.net/wp-content/plugins/social-warfare/assets/js/post-editor/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='srp-layout-stylesheet-css'  href='https://fasterland.net/wp-content/plugins/special-recent-posts/css/layout.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/6.0/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://c0.wp.com/c/6.0/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://c0.wp.com/c/6.0/wp-includes/js/mediaelement/wp-mediaelement.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://fasterland.net/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css'  href='https://fasterland.net/wp-content/plugins/social-warfare/assets/css/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C700%2C400italic%2C700italic' type='text/css' media='all' />
<link rel='stylesheet' id='bones-stylesheet-css'  href='https://fasterland.net/wp-content/themes/fasterland2/library/css/style.css' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='bones-ie-only-css'  href='https://fasterland.net/wp-content/themes/fasterland2/library/css/ie.css' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/11.0/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://fasterland.net/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/fasterland.net","hash_tracking":"false","ua":"UA-50305127-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://fasterland.net/wp-content/themes/fasterland2/library/js/libs/modernizr.custom.min.js' id='bones-modernizr-js'></script>
<link rel="https://api.w.org/" href="https://fasterland.net/wp-json/" /><link rel="alternate" type="application/json" href="https://fasterland.net/wp-json/wp/v2/posts/655" /><link rel='shortlink' href='https://wp.me/p4yZQZ-az' />
<link rel="alternate" type="application/json+oembed" href="https://fasterland.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html" />
<link rel="alternate" type="text/xml+oembed" href="https://fasterland.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html&#038;format=xml" />
<style>img#wpstats{display:none}</style>
	<style>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</style><style type="text/css" id="wp-custom-css">/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
div#disqus_thread {
	padding: 1em;
}

/*Forgot to add */
section ul {
  list-style-type: disc;
	padding: 1em;
}</style>		
				
		<!-- AdSense level page ads -->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		  (adsbygoogle = window.adsbygoogle || []).push({
			google_ad_client: "ca-pub-2118739050908640",
			enable_page_level_ads: true
		  });
		</script>

	</head>

	<body class="post-template-default single single-post postid-655 single-format-standard wp-custom-logo" itemscope itemtype="http://schema.org/WebPage">

		<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.js" type="text/javascript"></script>
		<script type="text/javascript">

			$(document).ready(function(){
				function getViewportWidth() {
				    var viewportWidth = $(window).width();

						return viewportWidth;
				}

				function showHideNavbar() {
						var viewportWidth = getViewportWidth();

						if (viewportWidth < 1030) {
								$(".nav").hide();
								$(".show_hide").show();

								if (viewportWidth < 768) {
									$(".header-social-icon").hide();
								}
								else {
									$(".header-social-icon").show();
								}
						}
						else {
								$(".nav").show();
								$(".header-social-icon").show();
								$(".show_hide").hide();
						}

						/*console.log('Viewport Width: ' + viewportWidth + ' px')*/
				}

				showHideNavbar();

				$('.show_hide').click(function(){
						var viewportWidth = getViewportWidth();

						$(".nav").slideToggle();

						if (viewportWidth < 768)
							$(".header-social-icon").slideToggle();

						console.log('Viewport Width: ' + viewportWidth + ' px');
				});

				$(window).resize(function() {
						showHideNavbar()
				});
			});

		</script>

		<div id="container">

			<header class="header" role="banner" itemscope itemtype="http://schema.org/WPHeader">

				<div id="inner-header">

					
				 	<a href="https://fasterland.net" rel="nofollow">
				 		<img id="logo" alt="Faster in Design logo" src="https://fasterland.net/wp-content/themes/fasterland2/res/fasterland_logo.png" />
					</a>

					<div class="nav-icon">
						<a href="#" class="show_hide">
								<img alt="nav icon" src="https://fasterland.net/wp-content/themes/fasterland2/res/nav-icn.png" />
						</a>
					</div>

					<div class="header-social-icon">
							<a href="https://www.facebook.com/fasterland.net" rel="nofollow" target="_blank">
									<img alt="Fasterland on Facebook" src="https://fasterland.net/wp-content/themes/fasterland2/res/social_icons/facebook.png" />
							</a>

							<a href="https://twitter.com/faster3ck" rel="nofollow" target="_blank">
									<img alt="Me on Twitter" src="https://fasterland.net/wp-content/themes/fasterland2/res/social_icons/twitter.png" />
							</a>

							<a href="https://plus.google.com/u/0/+FasterlandNet" rel="nofollow" target="_blank">
									<img alt="Fasterland on Google Plus" src="https://fasterland.net/wp-content/themes/fasterland2/res/social_icons/google+.png" />
							</a>

							<a href="https://github.com/Faster3ck/" rel="nofollow"target="_blank">
									<img alt="Me on GitHub" src="https://fasterland.net/wp-content/themes/fasterland2/res/social_icons/github.png" />
							</a>

							<a href="/feed" rel="nofollow" target="_blank">
									<img alt="RSS!" src="https://fasterland.net/wp-content/themes/fasterland2/res/social_icons/rss.png" />
							</a>
					</div>

										

					<nav role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
						<ul id="menu-top-menu" class="nav top-nav cf"><li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-57"><a href="https://fasterland.net/projects">Projects</a>
<ul class="sub-menu">
	<li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60"><a title="Converseen" href="https://fasterland.net/projects/converseen-batch-image-processor-tool">Converseen</a></li>
	<li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59"><a title="Kawaii Emoji Messenger" href="https://fasterland.net/projects/kawaii-emoji-messenger-facebook-desktop-messenger-emojis">Kawaii Emoji Messenger</a></li>
	<li id="menu-item-58" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58"><a title="Random Wordlist Generator" href="https://fasterland.net/projects/random-wordlist-generator-generate-random-wordlist-test-passwords-security">Random Wordlist Generator</a></li>
</ul>
</li>
<li id="menu-item-62" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62"><a href="https://fasterland.net/contact">Contact me</a></li>
<li id="menu-item-65" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-65"><a href="https://fasterland.net/about-me">About me</a>
<ul class="sub-menu">
	<li id="menu-item-326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-326"><a href="https://fasterland.net/cookie-policy">Cookie Policy</a></li>
</ul>
</li>
</ul>
					</nav>

				</div>

			</header>

			<div id="content">

				<div id="inner-content" class="wrap cf">

									<div id="sidebar1" class="sidebar m-all t-1of3 d-2of7 last-col cf" role="complementary">

					
						<div id="text-2" class="widget widget_text"><h4 class="widgettitle">Follow Me!</h4>			<div class="textwidget"><div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v14.0&appId=332215430451533&autoLogAppEvents=1" nonce="Gac3tSlq"></script>

<div class="fb-page" data-href="https://www.facebook.com/fasterland.net" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/fasterland.net" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/fasterland.net">Fasterland</a></blockquote></div>

<style type="text/css">
.tg  {style="margin: 0px auto;"}
.tg td{padding:10px 5px;}
.tg th{padding:10px 5px;}
.tg .tg-s6z2{text-align:center}
</style>
<table align="center" class="tg">
  <tr>
    <th class="tg-031e"><a href="https://twitter.com/faster3ck" class="twitter-follow-button" data-show-count="false">Follow @faster3ck</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></th>
    <th class="tg-s6z2"><div class="g-follow" data-annotation="bubble" data-height="20" data-href="//plus.google.com/u/0/112325748428859962380" data-rel="publisher"></div></th>
  </tr>
</table></div>
		</div><div id="text-3" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Fasterland Giganterrimo -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:1050px"
     data-ad-client="ca-pub-2118739050908640"
     data-ad-slot="1887224175"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
		</div><div id="wdg_specialrecentpostsfree-2" class="widget widget_specialrecentpostsFree"><h3 class="widget-title srp-widget-title">Recent posts</h3><!-- BEGIN Special Recent Posts FREE Edition v2.0.4 --><div class="srp-widget-container"><div id="wdg_specialrecentpostsfree-2-srp-singlepost-1" class="srp-widget-singlepost"><div class="srp-post-content-container"><div class="srp-thumbnail-box"><a class="srp-post-thumbnail-link" href="https://fasterland.net/converseen-image-converter-is-available-on-flathub.html" title="Converseen Image Converter is Available on Flathub"><img src="https://fasterland.net/wp-content/plugins/special-recent-posts/cache/srpthumb-p643-100x100-no.jpg" class="srp-post-thumbnail" alt="Converseen Image Converter is Available on Flathub" /></a></div><div class="srp-content-box"><h3 class="srp-post-title"><a class="srp-post-title-link" href="https://fasterland.net/converseen-image-converter-is-available-on-flathub.html" title="Converseen Image Converter is Available on Flathub">Converseen Image Converter is Available on Flathub</a></h3><p class="srp-post-date">June 27th, 2022</p></div></div></div><div id="wdg_specialrecentpostsfree-2-srp-singlepost-2" class="srp-widget-singlepost"><div class="srp-post-content-container"><div class="srp-thumbnail-box"><a class="srp-post-thumbnail-link" href="https://fasterland.net/how-to-resize-images-in-linux-kde-plasma-dolphin-with-reimage.html" title="How to Resize Images in Linux KDE Plasma Dolphin with ReImage"><img src="https://fasterland.net/wp-content/plugins/special-recent-posts/cache/srpthumb-p610-100x100-no.jpg" class="srp-post-thumbnail" alt="How to Resize Images in Linux KDE Plasma Dolphin with ReImage" /></a></div><div class="srp-content-box"><h3 class="srp-post-title"><a class="srp-post-title-link" href="https://fasterland.net/how-to-resize-images-in-linux-kde-plasma-dolphin-with-reimage.html" title="How to Resize Images in Linux KDE Plasma Dolphin with ReImage">How to Resize Images in Linux KDE Plasma Dolphin with ReImage</a></h3><p class="srp-post-date">April 7th, 2022</p></div></div></div><div id="wdg_specialrecentpostsfree-2-srp-singlepost-3" class="srp-widget-singlepost"><div class="srp-post-content-container"><div class="srp-thumbnail-box"><a class="srp-post-thumbnail-link" href="https://fasterland.net/fix-horizontal-lines-on-youtube-in-chrome-linux.html" title="Fix Horizontal Lines on YouTube in Chrome Linux"><img src="https://fasterland.net/wp-content/plugins/special-recent-posts/cache/srpthumb-p594-100x100-no.jpg" class="srp-post-thumbnail" alt="Fix Horizontal Lines on YouTube in Chrome Linux" /></a></div><div class="srp-content-box"><h3 class="srp-post-title"><a class="srp-post-title-link" href="https://fasterland.net/fix-horizontal-lines-on-youtube-in-chrome-linux.html" title="Fix Horizontal Lines on YouTube in Chrome Linux">Fix Horizontal Lines on YouTube in Chrome Linux</a></h3><p class="srp-post-date">March 29th, 2022</p></div></div></div><div id="wdg_specialrecentpostsfree-2-srp-singlepost-4" class="srp-widget-singlepost"><div class="srp-post-content-container"><div class="srp-thumbnail-box"><a class="srp-post-thumbnail-link" href="https://fasterland.net/how-to-restrict-internet-access-to-a-single-program-on-arch-linux-with-firejail.html" title="How to Restrict Internet Access to a Single Program on Arch Linux with Firejail"><img src="https://fasterland.net/wp-content/plugins/special-recent-posts/cache/srpthumb-p584-100x100-no.jpg" class="srp-post-thumbnail" alt="How to Restrict Internet Access to a Single Program on Arch Linux with Firejail" /></a></div><div class="srp-content-box"><h3 class="srp-post-title"><a class="srp-post-title-link" href="https://fasterland.net/how-to-restrict-internet-access-to-a-single-program-on-arch-linux-with-firejail.html" title="How to Restrict Internet Access to a Single Program on Arch Linux with Firejail">How to Restrict Internet Access to a Single Program on Arch Linux with Firejail</a></h3><p class="srp-post-date">March 22nd, 2022</p></div></div></div><div id="wdg_specialrecentpostsfree-2-srp-singlepost-5" class="srp-widget-singlepost"><div class="srp-post-content-container"><div class="srp-thumbnail-box"><a class="srp-post-thumbnail-link" href="https://fasterland.net/how-to-fix-buzzing-sound-speakers-archlinux-intel-chipset.html" title="How to Fix Buzzing Sound from Speakers on Arch Linux with Intel Chipset"><img src="https://fasterland.net/wp-content/plugins/special-recent-posts/cache/srpthumb-p554-100x100-no.png" class="srp-post-thumbnail" alt="How to Fix Buzzing Sound from Speakers on Arch Linux with Intel Chipset" /></a></div><div class="srp-content-box"><h3 class="srp-post-title"><a class="srp-post-title-link" href="https://fasterland.net/how-to-fix-buzzing-sound-speakers-archlinux-intel-chipset.html" title="How to Fix Buzzing Sound from Speakers on Arch Linux with Intel Chipset">How to Fix Buzzing Sound from Speakers on Arch Linux with Intel Chipset</a></h3><p class="srp-post-date">July 7th, 2021</p></div></div></div></div><!-- END Special Recent Posts FREE Edition v2.0.4 --></div>
					
				</div>

					<main id="main" class="m-all t-2of3 d-5of7 cf" role="main" itemscope itemprop="mainContentOfPage" itemtype="http://schema.org/Blog">

						
							
              
              <article id="post-655" class="cf post-655 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-arch-linux tag-news tag-vim" role="article" itemscope itemprop="blogPost" itemtype="http://schema.org/BlogPosting">



                <header class="article-header entry-header">

                  <h1 class="entry-title single-title" itemprop="headline" rel="bookmark">Vim 9.0 is Available on Arch Linux</h1>

                      <div class="cat-highlighter">
                        <a href="https://fasterland.net/category/news" rel="category tag">News</a>                      </div>

                   <p class="byline entry-meta vcard">
                      By <span class="by"></span> <span class="entry-author author" itemprop="author" itemscope itemptype="http://schema.org/Person"><a href='https://fasterland.net/author/faster3ck' title='Posts by <a href="http://fasterland.net" title="Visit Francesco Mondello&#8217;s website" rel="author external">Francesco Mondello</a>' rel='author'><a href="http://fasterland.net" title="Visit Francesco Mondello&#8217;s website" rel="author external">Francesco Mondello</a></a></span> on <time class="updated entry-time" datetime="2022-06-30" itemprop="datePublished">June 30, 2022</time>                    </p>


                    <div class="attachment-bones-thumb-custom">
                    <img width="750" height="500" src="https://i0.wp.com/fasterland.net/wp-content/uploads/2022/06/vim.png?fit=750%2C500&amp;ssl=1" class="attachment-bones-thumb-custom size-bones-thumb-custom wp-post-image" alt="vim arch linux text editor" srcset="https://i0.wp.com/fasterland.net/wp-content/uploads/2022/06/vim.png?w=1000&amp;ssl=1 1000w, https://i0.wp.com/fasterland.net/wp-content/uploads/2022/06/vim.png?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/fasterland.net/wp-content/uploads/2022/06/vim.png?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/fasterland.net/wp-content/uploads/2022/06/vim.png?resize=750%2C500&amp;ssl=1 750w" sizes="(max-width: 750px) 100vw, 750px" />                   </div>

                </header> 
                <section class="entry-content cf" itemprop="articleBody">
                  <div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="bottom" data-transition="slide" data-post-id="655" ><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Vim+9.0+is+Available+on+Arch+Linux&url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html&via=faster3ck" data-link="https://twitter.com/intent/tweet?text=Vim+9.0+is+Available+on+Arch+Linux&url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html&via=faster3ck"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt" ><span class="swp_count ">0 <span class="swp_label">Shares</span></span></div></div><p><strong>Vim 9.0</strong>, the terminal text editor has been updated with a major release and it&#8217;s already available on <strong>Arch Linux</strong>.</p>
<p>The previous release was <strong>version 8.2</strong> in <strong>December 2019</strong>.</p>
<p><span id="more-655"></span></p>
<h2>Vim in a few Words</h2>
<p>Vim is a free and open-source, screen-based text editor program. The program is designed for use both from a command-line interface and as a standalone application in a graphical user interface. Vim is released under the Vim license, which includes some charityware clauses that encourage users who enjoy the software to <a href="https://vimhelp.org/uganda.txt.html#license" target="_blank" rel="noopener">consider donating to children in Uganda</a>.</p>
<p>The Vim license is compatible with the GNU General Public License through a special clause allowing distribution of modified copies under the GNU GPL version 2.0 or later.</p>
<p>Since its release for the Amiga, cross-platform development has made it available on many other systems.</p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2118739050908640"
     crossorigin="anonymous"></script>
<!-- fasterland-quadrato -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2118739050908640"
     data-ad-slot="4056756356"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<h2>What&#8217;s New in Vim 9.0?</h2>
<p>The main update is <strong>Vim9 script</strong>, that brings performance impovements. Moreover, there are dozen of little improvements and new features that can be found <a href="https://www.vim.org/vim90.php" target="_blank" rel="noopener">here</a>.</p>
<h2>How to Install/Update to Vim 9.0 on Arch Linux</h2>
<p>In order to install <strong>Vim 9.0</strong> on <a href="https://wiki.archlinux.org/title/vim#Installation" target="_blank" rel="noopener"><strong>Arch Linux</strong></a>:</p>
<blockquote><p>$ sudo pacman -Sy vim</p></blockquote>
<p>If <strong>Vim</strong> it&#8217;s already installed on your system, you can update your installed packages with the command:</p>
<blockquote><p>$ sudo pacman -Syu</p></blockquote>
<p><strong>Vim</strong> is also available as an <a href="https://github.com/vim/vim-appimage/releases/tag/v9.0.0009" target="_blank" rel="noopener">AppImage package</a>.</p>
<p>&nbsp;</p>
<div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_individual_full_color swp_other_full_color scale-100  scale-" data-min-width="1100" data-float-color="#ffffff" data-float="bottom" data-float-mobile="bottom" data-transition="slide" data-post-id="655" ><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Vim+9.0+is+Available+on+Arch+Linux&url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html&via=faster3ck" data-link="https://twitter.com/intent/tweet?text=Vim+9.0+is+Available+on+Arch+Linux&url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html&via=faster3ck"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Ffasterland.net%2Fvim-9-0-is-available-on-arch-linux.html"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt" ><span class="swp_count ">0 <span class="swp_label">Shares</span></span></div></div><div class="swp-content-locator"></div><!-- AI CONTENT END 1 -->
                </section> 
                <footer class="article-footer">

                  <p class="tags"><span class="tags-title">Tags:</span> <a href="https://fasterland.net/tag/arch-linux" rel="tag">Arch Linux</a>, <a href="https://fasterland.net/tag/news" rel="tag">News</a>, <a href="https://fasterland.net/tag/vim" rel="tag">Vim</a></p>
                </footer> 
                

  
  

              </article> 
						
						
					</main>

				</div>

			</div>

			<footer class="footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">

				<div id="inner-footer" class="wrap cf">
          <div class="footer-logo"></div>
				  <div class="footer-deco"></div>

						<div class="footer-links"><ul id="menu-footer-menu" class=""><li id="menu-item-69" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69"><a href="https://fasterland.net/projects">Projects</a></li>
<li id="menu-item-67" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67"><a href="https://fasterland.net/about-me">About me</a></li>
<li id="menu-item-68" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68"><a href="https://fasterland.net/contact">Contact me</a></li>
<li id="menu-item-360" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-360"><a href="https://fasterland.net/cookie-policy">Cookie Policy</a></li>
</ul></div>
          <div class="source-org copyright">
            <a rel="license" href="http://creativecommons.org/licenses/by-nc-sa/4.0/"><img alt="Creative Commons License" style="border-width:0" src="http://i.creativecommons.org/l/by-nc-sa/4.0/88x31.png" /></a><br /><span xmlns:dct="http://purl.org/dc/terms/" property="dct:title">Fasterland</span> by <a xmlns:cc="http://creativecommons.org/ns#" href="http://fasterland.net/" property="cc:attributionName" rel="cc:attributionURL">Francesco Mondello</a> is licensed under a <a rel="license" href="http://creativecommons.org/licenses/by-nc-sa/4.0/">Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License</a>.
          </div>

				</div>

			</footer>

		</div>

				<script type='text/javascript' src='https://c0.wp.com/p/jetpack/11.0/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/6.0/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/fasterland.net\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://fasterland.net/wp-content/plugins/contact-form-7/includes/js/index.js' id='contact-form-7-js'></script>
<script type='text/javascript' id='social_warfare_script-js-extra'>
/* <![CDATA[ */
var socialWarfare = {"addons":[],"post_id":"655","variables":{"emphasizeIcons":false,"powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://fasterland.net/wp-content/plugins/social-warfare/assets/js/script.min.js' id='social_warfare_script-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LeJft4UAAAAAIs5-Tlb5LdxliEZx_DCJP2TzIF3' id='google-recaptcha-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LeJft4UAAAAAIs5-Tlb5LdxliEZx_DCJP2TzIF3","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://fasterland.net/wp-content/plugins/contact-form-7/modules/recaptcha/index.js' id='wpcf7-recaptcha-js'></script>
<script type='text/javascript' src='https://fasterland.net/wp-content/themes/fasterland2/library/js/scripts.js' id='bones-js-js'></script>
<script type="text/javascript"> var swp_nonce = "fb39256201";var swpFloatBeforeContent = false; var swp_ajax_url = "https://fasterland.net/wp-admin/admin-ajax.php"; var swp_post_id = "655";var swpClickTracking = false;</script><div class="demo-wrapper" style="display:none;"><div class="ads"><img id="chp-ads-image" src="images/ads.jpg" height="250" width="300" alt=""></div></div><!-- The Modal -->
<div id="chp_ads_block_modal_newjFMAEt8EapuortiNWuNL5OhxXXuNv4" class="chp_ads_block_modaljFMAEt8EapuortiNWuNL5OhxXXuNv4 fadeInDown">
    <div class="chp_ads_block_modal_content" id="chp_ads_block_modal_content">
        <div class="chp_ads_block_pro_body" id="chp_ads_block_pro_body">
            <div class="chp_ads_block_detector_theme theme1">
                <div class="chp_ads_block_pro_body">

                    <div class="chp_ads_blocker_wrapper">
                        <img class="chp_ads_blocker_detector-icon" src="https://fasterland.net/wp-content/plugins/chp-ads-block-detector/assets/img/icon.png" alt="Ads Blocker Image Powered by Code Help Pro">                    </div>

                    <h4 class="adblock_title">Ads Blocker Detected!!!</h4>
                    <div class="adblock_subtitle"><p>We have detected that you are using extensions to block ads. Please support us by disabling these ads blocker.</p></div>


                    <div class="chp_ads_blocker_detector-action">
                                                 <a
                            class="chp_ads_blocker_detector-action-btn-ok"
                            onclick="reload()">Refresh</a>
                                            </div>
                </div>
            </div>
        </div>
    </div>

    <div class="chp_brandingjFMAEt8EapuortiNWuNL5OhxXXuNv4"><a id="chp_brandingjFMAEt8EapuortiNWuNL5OhxXXuNv4" href="https://codehelppro.com/product/wordpress/plugin/chp-ads-block-detector-pro/" target="_blank" rel="noopener noreferrer"><span class="chp_brading_powered_by" style="color: rgb(9, 13, 22);">Powered By</span> <div class="chp_brading_svg"><img src="https://fasterland.net/wp-content/plugins/chp-ads-block-detector/assets/img/branding.svg" alt="CHP Adblock Detector Plugin | Codehelppro" /></div></a></div></div>

<script>
    const adblockModal=document.getElementById("chp_ads_block_modal_newjFMAEt8EapuortiNWuNL5OhxXXuNv4");const adbEnableForPage=true;const debug=false;const adbVersion="3.6";const ajaxurl="https://fasterland.net/wp-admin/admin-ajax.php";let onPageLoad=true;let googleAdsControl=true;let imageAdsControl=true;let classAdsControl=true;let displayOnce=0;let adsRequestURL="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js";const brandingBtn=document.getElementById("chp_brandingjFMAEt8EapuortiNWuNL5OhxXXuNv4");if(brandingBtn){brandingBtn.addEventListener("click",function(event){event.preventDefault();window.location.href="https://codehelppro.com/product/wordpress/plugin/chp-ads-block-detector-pro/";return false;});}
const adblockCloseBtn=document.getElementById("close_btn_adblockjFMAEt8EapuortiNWuNL5OhxXXuNv4");if(adblockCloseBtn){adblockCloseBtn.onclick=function(){hide_model();}}
function is_connected(){try{return window.navigator.onLine;}catch(error){return true;}}
function adsBlocked(callBackFunc){if(googleAdsControl&&is_connected()){let adsRequest=new Request(adsRequestURL,{method:"HEAD",mode:"no-cors"});fetch(adsRequest).then(function(res){if(debug){console.warn("[ADB DEBUG] Google Ads Request Passed!!!");}
callBackFunc(false);}).catch(function(res){if(debug){console.warn("[ADB DEBUG] Google Ads Request Failed!!!");console.warn(`[ADB DEBUG] ${res}`)}
callBackFunc(true);})}else{if(debug){console.warn("[ADB DEBUG] Google Ads Request Blocked by Filter Hook or Offline!!!");}}
callBackFunc(false);}
function chpadb_default_callback(e){console.log(e)}
function reload(){window.location.href=window.location.href}
function redirect(e){window.location.href=e}
function hasClass(e,t){return!!e.className.match(new RegExp("(\\s|^)"+t+"(\\s|$)"))}
function addClass(e,t){hasClass(e,t)||(e.className+=" "+t)}
function removeClass(e,t){if(hasClass(e,t)){var o=new RegExp("(\\s|^)"+t+"(\\s|$)");e.className=e.className.replace(o," ")}}
let count=0;function hide_model(){try{if(typeof adblockModal=='object'){removeClass(adblockModal,"chp_ads_blocker_detector-showjFMAEt8EapuortiNWuNL5OhxXXuNv4");removeClass(document.body,"chp_ads_blocker_detector_activejFMAEt8EapuortiNWuNL5OhxXXuNv4")}}catch(e){console.warn(e);}}
function show_modal(modal){if(modal!=null&&0==displayOnce){displayOnce++;addClass(modal,"chp_ads_blocker_detector-showjFMAEt8EapuortiNWuNL5OhxXXuNv4");addClass(document.body,"chp_ads_blocker_detector_activejFMAEt8EapuortiNWuNL5OhxXXuNv4")}}
function chp_adblock_browser(){return /Opera[\/\s](\d+\.\d+)/.test(navigator.userAgent)?"Opera":/MSIE (\d+\.\d+);/.test(navigator.userAgent)?"MSIE":/Navigator[\/\s](\d+\.\d+)/.test(navigator.userAgent)?"Netscape":/Chrome[\/\s](\d+\.\d+)/.test(navigator.userAgent)?"Chrome":/Safari[\/\s](\d+\.\d+)/.test(navigator.userAgent)?"Safari":/Firefox[\/\s](\d+\.\d+)/.test(navigator.userAgent)?"Firefox":"Unknown"}
function chp_ads_blocker_detector(enable){if(enable){show_modal(adblockModal);}}
let prevCount=0;function checkMultiple(){let enable=false;if(classAdsControl){let divEle=document.createElement("div");divEle.innerHTML="&nbsp;";divEle.className="ad ads doubleclick ad-placement ad-placeholder adbadge BannerAd adsbox";divEle.id="filter_ads_by_classname";try{if(!document.body.contains(document.getElementById('filter_ads_by_classname'))){document.body.appendChild(divEle);let adBoxEle=document.querySelector(".adsbox");enable=!adBoxEle||adBoxEle.offsetHeight==0;if(debug){if(enable){console.warn("[ADB DEBUG] Class Add Request Failed!!!");}else{console.log("[ADB DEBUG] Class Add Request Passed!!!");}}}else{let adBoxEleId=document.getElementById("filter_ads_by_classname");removeClass(adBoxEleId,` ads_${prevCount}`);removeClass(adBoxEleId,`ads_${prevCount}`);prevCount++;addClass(adBoxEleId,`ads_${prevCount}`);}}catch(error){divEle.parentNode.removeChild(divEle);}}else{if(debug){console.warn("[ADS PRO DEBUG] Check Multiple Request Blocked by Filter Hook or Offline");}}
return enable;}
function isHidden(e){return"none"===window.getComputedStyle(e).display}
function init(){adsBlocked(function(enable){if(enable){chp_ads_blocker_detector(true);}else{if(imageAdsControl){enable=isHidden(document.getElementById("chp-ads-image"));if(debug){if(enable){console.warn("[ADB DEBUG] Image Ads Request Failed!!!");}else{console.log("[ADB DEBUG] Image Ads Request Passed!!!");}}}
if(!enable){enable=checkMultiple();if(debug){if(enable){console.warn("[ADB DEBUG] Check Multiple Request Failed!!!");}else{console.log("[ADB DEBUG] Check Multiple Request Passed!!!");}}}
chp_ads_blocker_detector(enable)}})}
function startCheckingAdblock(){init();}
if(adbEnableForPage){if(onPageLoad){document.addEventListener("DOMContentLoaded",function(e){startCheckingAdblock();},false);}else{startCheckingAdblock();}}</script><script src='https://stats.wp.com/e-202226.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0',blog:'67446265',post:'655',tz:'0',srv:'fasterland.net'} ]);
	_stq.push([ 'clickTrackerInit', '67446265', '655' ]);
</script>

	</body>

</html> <!-- end of site. what a ride! -->
